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Related URL 
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Element Specification
RelatedURL (0..*)
RelatedURL/URL (1)
RelatedURL/Description (0..1)
RelatedURL/URLContentType (1) <CollectionURL, PublicationURL, DataCenterURL, DistributionURL, DataContactURL, VisualizationURL>
RelatedURL/Type (1) {Valid values shown below}
RelatedURL/Subtype (0..1) {Valid values shown below}
RelatedURL/GetData (0..1)
RelatedURL/GetData/Format (1) <ascii, binary, GRIB, BUFR, HDF4, HDF5, HDF-EOS4, HDF-EOS5, jpeg, png, tiff, geotiff, kml, Not provided>
RelatedURL/GetData/MimeType (0..1) {Valid values shown below}
RelatedURL/GetData/Size (1)
RelatedURL/GetData/Unit (1) <KB, MB, GB, TB, PB>
RelatedURL/GetData/Fees (0..1)
RelatedURL/GetData/Checksum (0..1)
RelatedURL/GetService (0..1)
RelatedURL/GetService/Format (0..1) <ascii, binary, GRIB, BUFR, HDF4, HDF5, HDF-EOS4, HDF-EOS5, jpeg, png, tiff, geotiff, kml, Not provided>
RelatedURL/GetService/MimeType (1) {Valid values shown below}
RelatedURL/GetService/Protocol (1) <ESI, FTP, FTPS, HTTP, HTTPS, OPeNDAP, WCS, WMS, Not provided>
RelatedURL/GetService/FullName (1)
RelatedURL/GetService/DataID (1)
RelatedURL/GetService/DataType (1)
RelatedURL/GetService/URI (0..*)
 
Valid Values for
· URLContentType
· Type
· Subtype
 
	· DistributionURL
· DOWNLOAD SOFTWARE
·  
· MOBILE APP
· GET DATA
·  
· APPEARS
· DATA COLLECTION BUNDLE
· DATA TREE
· DATACAST URL
· DIRECT DOWNLOAD
· Earthdata Search
· EOSDIS DATA POOL
· GIOVANNI
· GoLIVE Portal
· IceBridge Portal
· LAADS
· LANCE
· MIRADOR
· MODAPS
· NOAA CLASS
· NOMADS
· Order
· PORTAL
· Subscribe
· USGS EARTH EXPLORER
· VERTEX
· VIRTUAL COLLECTION
· GOTO WEB TOOL
·  
· LIVE ACCESS SERVER (LAS)
· MAP VIEWER
· SIMPLE SUBSET WIZARD (SSW)
· SUBSETTER
· USE SERVICE API
·  
· GRADS DATA SERVER (GDS)
· MAP SERVICE
· OPENDAP DATA
· OpenSearch
· SERVICE CHAINING
· TABULAR DATA STREAM (TDS)
· THREDDS DATA
· WEB COVERAGE SERVICE (WCS)
· WEB FEATURE SERVICE (WFS)
· WEB MAP SERVICE (WMS)
· WEB MAP TILE SERVICE (WMTS)
· VisualizationURL
· GET RELATED VISUALIZATION
·  
· WORLDVIEW
· GIOVANNI
· MAP
	· CollectionURL
· DATA SET LANDING PAGE
·  
· EXTENDED METADATA
·  
· PROFESSIONAL HOME PAGE
·  
· PROJECT HOME PAGE
·  
· PublicationURL
· VIEW RELATED INFORMATION
·  
· ALGORITHM DOCUMENTATION
· ALGORITHM THEORETICAL BASIS DOCUMENT (ATBD)
· ANOMALIES
· CASE STUDY
· DATA CITATION POLICY
· DATA QUALITY
· DATA RECIPE
· DELIVERABLES CHECKLIST
· GENERAL DOCUMENTATION
· HOW-TO
· IMPORTANT NOTICE
· INSTRUMENT/SENSOR CALIBRATION DOCUMENTATION
· MICRO ARTICLE
· PI DOCUMENTATION
· PROCESSING HISTORY
· PRODUCT HISTORY
· PRODUCT QUALITY ASSESSMENT
· PRODUCT USAGE
· PRODUCTION HISTORY
· PUBLICATIONS
· READ-ME
· REQUIREMENTS AND DESIGN
· SCIENCE DATA PRODUCT SOFTWARE DOCUMENTATION
· SCIENCE DATA PRODUCT VALIDATION
· USER FEEDBACK PAGE
· USER'S GUIDE
· DataCenterURL
· HOME PAGE
·  
· DataContactURL
· HOME PAGE
·  

	 
	 


 
Valid values for RelatedURL/GetService/MimeType:
	· application/json
· application/xml
· application/x-netcdf
· application/gml+xml
· application/vnd.google-earch.kml+xml
· image/gif
· image/tiff
· image/bmp
· text/csv
· text/xml
	· application/pdf
· application/x-hdf
· application/xhdf5
· application/octet-stream
· application/vnd.google-earth.kmz
· image/jpeg
· image/png
· image/vnd.collada+xml
· text/html
· text/plain


 
Description
This element describes any resource-related URLs that include project home pages, resource information pages, services, related data, archives/servers, metadata extensions, direct links to online software packages, web mapping services, links to images, documents, or other data. When filling out this element URLContentType and Type are required - Description and Subtype are optional. If the URLContentType is DistributionURL and the Type is GET DATA, DOWNLOAD SOFTWARE, or GOTO WEB TOOL, then the RelatedURL/GetData sub-elements are also filled out. If the URLContentType is DistributionURL and the Type is USE SERVICE API, then the RelatedURL/GetService sub-elements are also filled out.
•    RelatedURL - contains URLs to data or services (e.g., Distribution URLs).
•    GetData - information about the data (e.g., format, size, units, fees, checksum).
•    GetService - contains Universal Resource Identifiers (URI)s to data via services and information about the data and service (e.g. mime type, protocol, name, data IDs, data type).
The valid values for Type and Subtype were derived and tailored from the Global Change Master Directory (GCMD) RelatedURL Type and Subtype elements. We looked at these values, categorized them, removed duplicates, and tailored them while preserving the mapping between the type and sub-type. It is our intent to work with GCMD and get back to a single set of values that can be controlled through the Keyword Management System (KMS).
 
Some use Examples:
I have a DAAC Home page that I would like to put into the metadata:
RelatedURL/URL = http://www.daachomepage.gov
RelatedURL/Description = The DAAC home page
RelatedURL/URLContentType = DataCenterURL
RelatedURL/Type = HOME PAGE
RelatedURL/Subtype =
 
I have a file that I can distribute to whomever is interested:
RelatedURL/URL = http://www.daachomepage.gov/path/downloadable.doc
RelatedURL/Description = some downloadable resource
RelatedURL/URLContentType = DistributionURL
RelatedURL/Type = GET DATA
RelatedURL/Subtype = DATA TREE
RelatedURL/GetData/Format = application/msword
RelatedURL/GetData/Size = 40
RelatedURL/GetData/Unit = MB
RelatedURL/GetData/Fees = 0
RelatedURL/GetData/Checksum = f5d30a4f2
 
I have a service that I can distribute a sub-setted variable:
RelatedURL/URL = http://oco2.gesdisc.eosdis.nasa.gov/opendap/
RelatedURL/Description = An OPeNDAP page to get data through a service
RelatedURL/URLContentType = DistributionURL
RelatedURL/Type = USE SERVICE API
RelatedURL/Subtype = OPENDAP DATA
RelatedURL/GetService/MimeType = application/x-netcdf
RelatedURL/GetService/Protocol = http
RelatedURL/GetService/FullName = OCO2_L1B_Science.7r
RelatedURL/GetService/DataID = OCO2_L1B_Science.7r
RelatedURL/GetService/DataType = nc4
RelatedURL/GetService/URI = http://oco2.gesdisc.eosdis.nasa.gov/opendap/OCO2_L1B_Science.7r/2015/015/oco2_L1bScND_02879a_150115_B7000r_150616093751.h5.nc4?_SoundingGeometry_sounding_latitude[0:1:8363][0:1:7],_SoundingGeometry_sounding_longitude[0:1:8363][0:1:7]
RelatedURL/GetService/URI = http://oco2.gesdisc.eosdis.nasa.gov/opendap/OCO2_L1B_Science.7r/2015/015/oco2_L1bScND_02879a_150115_B7000r_150616093751.h5.nc4?_SoundingGeometry_sounding_latitude[0:8363][0:7],_SoundingGeometry_sounding_longitude[0:8363][0:7]
RelatedURL/GetService/URI = http://oco2.gesdisc.eosdis.nasa.gov/opendap/OCO2_L1B_Science.7r/2015/015/oco2_L1bScND_02879a_150115_B7000r_150616093751.h5.nc4?_SoundingGeometry_sounding_latitude,_SoundingGeometry_sounding_longitude
 
Profile Utilization
Collection, Service
 
Cardinality
0..*
 
Mapping
DIF 9:
/DIF/Related_URL
/DIF/Multimedia_Sample
/DIF/Distribution
 
DIF 10:
/DIF/Related_URL
/DIF/Multimedia_Sample
/DIF/Distribution
 
ECHO 10 Collection:
/Collection/OnlineAccessURLs/OnlineAccessURL
/Collection/AssociatedBrowseImageUrls
/Collection/OnlineResources
/Collection/Price
/Collection/DataFormat
 
ISO 19115-2:
/gmi:MI_Metadata/gmd:distributionInfo/gmd:MD_Distribution/gmd:distributor/gmd:MD_Distributor/gmd:distributorTransferOptions/gmd:MD_DigitalTransferOptions/gmd:onLine/gmd:CI_OnlineResource
and/or
/gmi:MI_Metadata/gmd:identificationInfo/gmd:MD_DataIdentification/gmd:graphicOverview/gmd:MD_BrowseGraphic/gmd:fileName/gmx:FileName src=
 
Examples
DIF 9:
   <Related_URL>
      <URL_Content_Type uuid="6e72d128-7d28-4bd0-bac0-8c5ffd8b31f1">
     <Type>VIEW PROJECT HOME PAGE</Type>
      </URL_Content_Type>
      <URL>http://www.waisdivide.unh.edu/</URL>
   </Related_URL>
   <Related_URL>
      <URL_Content_Type uuid="5ec1bb9d-0efc-4099-9b31-ec791bbd8145">
     <Type>VIEW RELATED INFORMATION</Type>
      </URL_Content_Type>
      <URL>http://www.homepage.montana.edu/~lkbonney/</URL>
      <Description>
         Website for the Priscu Research Group
      </Description>
   </Related_URL>
 
<Multimedia_Sample>
   <URL>http://www.waisdivide.unh.edu/images/sitemap1_large.jpg</URL>/p>
   </Multimedia_Sample>
 
DIF 10:
    <Multimedia_Sample>
        <URL>http://disc.gsfc.nasa.gov/AIRS/images/G1932015.04.19allL1CBrightnessTemperature_K_at10.9microns_map.png</URL>
        <Format>PNG</Format>
        <Caption>The BT derived from an AIRS Level 1C granule for a channel at 10.9 microns.</Caption>
        <Description>Sample image of an AIRICRAD channel converted to brighness temperature</Description>
    </Multimedia_Sample>

    <Related_URL>
        <URL_Content_Type>
            <Type>GET DATA</Type>
            <Subtype>DATA TREE</Subtype>
        </URL_Content_Type>
        <URL>http://airsl1.gesdisc.eosdis.nasa.gov/data/Aqua_AIRS_Level1/AIRICRAD.006/</URL>
        <Description>Access the data via HTTP.</Description>
    </Related_URL>
    <Related_URL>
        <URL_Content_Type>
            <Type>GET DATA</Type>
            <Subtype>MIRADOR</Subtype>
        </URL_Content_Type>
        <URL>http://mirador.gsfc.nasa.gov/cgi-bin/mirador/homepageAlt.pl?keyword=AIRICRAD</URL>
        <Description>Mirador is a data search interface that allows searching, browsing, and retrieving of Earth science data archived at NASA GES DISC.</Description>
    </Related_URL>
    <Related_URL>
        <URL_Content_Type>
            <Type>GET DATA</Type>
        </URL_Content_Type>
        <URL>http://airsl1.gesdisc.eosdis.nasa.gov/opendap/Aqua_AIRS_Level1/AIRICRAD.006/contents.html</URL>
        <Description>Access the data via the OPeNDAP protocol.</Description>
    </Related_URL>
...
    <Related_URL>
        <URL_Content_Type>
            <Type>GET DATA</Type>
            <Subtype>EARTHDATA SEARCH</Subtype>
        </URL_Content_Type>
        <URL>https://search.earthdata.nasa.gov/search?q=AIRICRAD+006</URL>
        <Description>Use the Earthdata Search Client (EDSC) to find and retrieve data sets across multiple data centers.</Description>
    </Related_URL>
...
 
ECHO 10 Collection:
<OnlineAccessURLs>
   <OnlineAccessURL>
      <URL>http://sedac.ciesin.columbia.edu/data/set/ulandsat-cities-from-space/data-download</URL>
      <URLDescription>data download page</URLDescription>
   </OnlineAccessURL>
</OnlineAccessURLs>
<OnlineResources>
   <OnlineResource>
      <URL>http://dx.doi.org/10.7927/H4SQ8XB1</URL>
      <Description>data set DOI and homepage</Description> 
      <Type>DOI URL</Type>
   </OnlineResource>
</OnlineResources>
 
<AssociatedBrowseImageUrls>
    <ProviderBrowseUrl>
        <URL>http://sedac.ciesin.columbia.edu/data/set/ulandsat-cities-from-space/maps</URL>
    </ProviderBrowseUrl>
</AssociatedBrowseImageUrls>
 
ISO 19115-2:
<gmd:onLine>
      <gmd:CI_OnlineResource>
         <gmd:linkage>
            <gmd:URL>http://sedac.ciesin.columbia.edu/data/set/ulandsat-cities-from-space/data-download</gmd:URL>
         </gmd:linkage>
         <gmd:applicationProfile gco:nilReason="missing"/>
         <gmd:description>
            <gco:CharacterString>data download page</gco:CharacterString>
         </gmd:description>
         <gmd:function>
            <gmd:CI_OnLineFunctionCode codeList="http://www.isotc211.org/2005/resources/Codelist/gmxCodelists.xml#CI_OnLineFunctionCode" codeListValue="download">download</gmd:CI_OnLineFunctionCode>
         </gmd:function>
      </gmd:CI_OnlineResource>
   </gmd:onLine>
   <gmd:onLine>
      <gmd:CI_OnlineResource>
         <gmd:linkage>
            <gmd:URL>http://dx.doi.org/10.7927/H4SQ8XB1</gmd:URL>
         </gmd:linkage>
         <gmd:applicationProfile gco:nilReason="missing"/>
         <gmd:name>
            <gco:CharacterString>DOI URL</gco:CharacterString>
         </gmd:name>
         <gmd:description>
            <gco:CharacterString>data set DOI and homepage</gco:CharacterString>
         </gmd:description>
         <gmd:function>
            <gmd:CI_OnLineFunctionCode codeList="http://www.isotc211.org/2005/resources/Codelist/gmxCodelists.xml#CI_OnLineFunctionCode" codeListValue=""/>
         </gmd:function>
      </gmd:CI_OnlineResource>
   </gmd:onLine>
...
<gmd:graphicOverview>
  <gmd:MD_BrowseGraphic>
     <gmd:fileName>
        <gmx:FileName src="http://sedac.ciesin.columbia.edu/data/set/ulandsat-cities-from-space/maps"/>
     </gmd:fileName>
     <gmd:fileDescription>
        <gco:CharacterString>File Size:</gco:CharacterString>
     </gmd:fileDescription>
     <gmd:fileType gco:nilReason="missing"/>
  </gmd:MD_BrowseGraphic>
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